Many licensed and some free of charge script-driven apps have encoded code, which is not human readable. The idea behind this is to stop the reverse engineering as well as the unwanted use of such applications. One of the most popular encryption tools used for this specific purpose is called Zend Guard and it's used widely since it can be used to modify all PHP 4 or PHP 5 code. The only method for the encoded files to work properly on a web server afterwards is when one more instrument called Zend Optimizer is there. If you wish to use any kind of paid web software that needs Zend Optimizer, you should make sure that it's installed on the server where you will host your site. Also, sites which require the tool generally perform better as their code is already precompiled and optimized, meaning that it's executed more quickly.

Zend Optimizer in Cloud Hosting

Zend Optimizer is set up on all servers which are part of our state-of-the-art cloud website hosting platform. No matter which Linux cloud hosting you choose, you will be able to activate the software tool so that any script app which requires it will function properly as part of your account. By using a convenient software tool from the Advanced area of the Hepsia Control Panel that is provided with all of the hosting accounts, you can activate and deactivate different options with just a single button. Zend Optimizer is one of these, so even if this happens to be your very first web hosting account ever, you will not experience any troubles. In the exact same section you can also select the PHP version for your account - 4 and several versions of 5, therefore any time you switch to one that you have not used yet, you can enable Zend Optimizer for it with a click. Since our platform allows you to take advantage of a couple of PHP releases at the same time, more advanced users can enable the instrument for a specific website with a php.ini file in a specific domain folder as well.

Zend Optimizer in Semi-dedicated Hosting

Zend Optimizer is present on all of the servers that comprise our cluster hosting platform, therefore you'll be able to use it for all your script-driven applications with all of our semi-dedicated server plans. It'll be available all of the time even if you switch the PHP release for your account since our feature-rich platform will allow you to choose from PHP 4, 5.2, 5.3, 5.4 and 5.5. Both changing your version and activating Zend Optimizer for the new one takes just a couple of clicks in the PHP Configuration section of the Hepsia website hosting Control Panel which is used to manage the semi-dedicated accounts. What is more, you can also use a different version of PHP and enable or disable Zend for every single domain that you host in the account. This is possible by employing a php.ini file in a domain folder with just a couple of lines of program code inside it. In case you don't have previous experience and you are not sure how to do this, our 24/7 technical assistance can help you.