PHP, which is an initialism for PHP: Hypertext Preprocessor, is among the most widely used general-purpose programming languages that are available out there. Any website or web-based app built with PHP will run on a given server on the condition that a PHP module is installed, which makes the language absolutely universal and it is not a surprise that there are a few million web servers that support it and hundreds of millions of PHP-powered websites running on them. PHP is preferred over HTML owing to the fact that it enables you to create a dynamic serving site with an abundance of options. A PHP-based social network, for example, will serve unique web content to each user even though the page URL will stay the same. In comparison, HTML sites are static and the content on the pages can be edited only manually. Just like any other software, PHP has several versions and the version that was used whilst building a particular website must be available on the server in order for the site to run flawlessly.

PHP 4 and PHP 5 Support in Cloud Hosting

Our cloud hosting servers support different PHP versions, so your websites will run without any problems even if your PHP scripts are outdated. We realize that an old website does not inevitably equal an insecure one as you may have performed lots of modifications to its code. That is why we support PHP 5.5, 5.4, 5.3, 5.2 and 4 and you can pick which version will be active for your hosting account. The version can be changed with only one single click of the mouse within your Hepsia Control Panel and the new settings will be applied immediately. In case you’d like to run both older and newer scripts, there’s even an option to use a different PHP version for each of your domains at the same time.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

Our Linux semi-dedicated hosting services support multiple PHP versions, so you will be able to run all the web apps that you have developed throughout the years. The Hepsia Control Panel, which comes bundled with every account, will enable you to enable the required version with just one click. You can select between PHP 5.5, 5.4, 5.3, 5.2 and 4. In case you want to host multiple websites under the very same account and they have distinctive requirements towards the web hosting environment, you will be able to set a different PHP version for each and every one of them no matter which version is enabled for the account itself. This is accomplishable thanks to our in-house created cloud web hosting platform, which allows us to run multiple versions of PHP simultaneously. In contrast, the vast majority of hosting providers normally offer one, in exceptionally rare cases – two versions.